Excel bị lỗi calculating rất chậm

bdcs101

Thành viên mới
Tham gia ngày
12 Tháng mười hai 2007
Bài viết
2
Được thích
3
Điểm
0
Tuổi
35
Chào mọi người !

B có 1 file excel quản lý hàng hóa trong tháng. Nhưng cứ khoảng hơn 10 ngày, việc nhập hàng hóa vào thì excel xử lý rất chậm. Nhìn xuống màn hình thì thấy status của excel calculating liên tục. B đã thử trên nhiều máy vẫn bị trình trạng đó. Mọi người có biết đây là lỗi gì không ?
 

File đính kèm

chibi

Thành viên tích cực
Thành viên danh dự
Tham gia ngày
10 Tháng một 2007
Bài viết
1,123
Được thích
624
Điểm
860
File của bạn có nhiều công thức, mỗi lần thay đổi dữ liệu thì nó lại tính toán lại. Có thể ngắt chức năng tự động tính toán bằng Tools -> Options -> Calculation ->Menual. Lúc nào muốn tính thì F9.
 

bdcs101

Thành viên mới
Tham gia ngày
12 Tháng mười hai 2007
Bài viết
2
Được thích
3
Điểm
0
Tuổi
35
Thank Chibi !
B đã làm theo hướng dẫn và fix được lỗi này rồi.
Chúc chibi nhiều sức khỏe !
 

DOSNET

Thành viên gắn bó
Thành viên danh dự
Tham gia ngày
3 Tháng tám 2007
Bài viết
1,634
Được thích
2,361
Điểm
860
Tuổi
43
Nơi ở
Hà nội
Tôi đang thắc mắc ở chỗ này:
bdcs101 đã viết:
...Nhưng cứ khoảng hơn 10 ngày, việc nhập hàng hóa vào thì excel xử lý rất chậm.
Nếu bảng tính được thiết kế tốt thì nhập liệu mái thoải vẫn chạy ngon lành. Manual caculate chỉ là biện pháp tạm thời, nguyên nhân chính là cái file của bạn có vấn đề. Đôi lời góp ý !
 

salam

Thành viên gắn bó
Tham gia ngày
4 Tháng mười một 2006
Bài viết
1,926
Được thích
1,855
Điểm
860
Tuổi
45
Nơi ở
Quảng Ninh
Thế cứ nhập liệu xong lại F9 một cái àh nhỡ quên thì làm sao công thức không tự động tính => kết quả sai. Cái này là do file của bạn có nhiều công thức. Nên tối ưu nó mới được.
 

anhtuan1066

Thành viên gạo cội
Tham gia ngày
10 Tháng ba 2007
Bài viết
5,814
Được thích
6,836
Điểm
860
Tuổi
53
Nơi ở
Biên Hòa, Đồng Nai
salam đã viết:
Thế cứ nhập liệu xong lại F9 một cái àh nhỡ quên thì làm sao công thức không tự động tính => kết quả sai. Cái này là do file của bạn có nhiều công thức. Nên tối ưu nó mới được.
Quên bấm F9 cũng ko sai đâu, chẳng qua tạm thời nó đễ yên đó ko Refresh mới nên ta vẫn xem kq cũ... Đến lúc đóng file, save lại thì tất nhiên nó sẽ tính lại hết
ANH TUẤN
 

anhphuong

Thân Thương
Tham gia ngày
12 Tháng ba 2007
Bài viết
515
Được thích
2,590
Điểm
860
anhtuan1066 đã viết:
Quên bấm F9 cũng ko sai đâu, chẳng qua tạm thời nó đễ yên đó ko Refresh mới nên ta vẫn xem kq cũ... Đến lúc đóng file, save lại thì tất nhiên nó sẽ tính lại hết
ANH TUẤN
Đúng rồi nhưng cách tốt nhất là phải tối ưu CSDL cho hợp lý mới mong khắc phục được
 

DOSNET

Thành viên gắn bó
Thành viên danh dự
Tham gia ngày
3 Tháng tám 2007
Bài viết
1,634
Được thích
2,361
Điểm
860
Tuổi
43
Nơi ở
Hà nội
Đề nghị bạn gửi file lên diễn đàn để có sự trợ giúp tốt hơn, thân!
 

sixstar

Thành viên mới
Tham gia ngày
15 Tháng mười một 2011
Bài viết
9
Được thích
0
Điểm
0
Tôi đang thắc mắc ở chỗ này:

Nếu bảng tính được thiết kế tốt thì nhập liệu mái thoải vẫn chạy ngon lành. Manual caculate chỉ là biện pháp tạm thời, nguyên nhân chính là cái file của bạn có vấn đề. Đôi lời góp ý !
Bạn nói đúng rồi, có thể fix tạm thời bằng cách manual calculating, nhưng như thế rất bất tiện.
Nhờ bạn xem qua cái file này giúp mình với, làm sao để tối ưu hóa nó, ko bị auto cal. mà vãn update dc công thức trong từng thao tác.
file minh 13mb lựng, nặng quá nên ko attach dc
 

kimdong80

Thành viên chính thức
Tham gia ngày
26 Tháng ba 2008
Bài viết
88
Được thích
8
Điểm
670
Tuổi
39
Mình có 1 file chừng 40kb thôi. Mở ở máy 3-4 máy khác nhau thì bị lỗi: mỗi lần nhập thêm hay copy (nói chung là bất cứ thao tác gì) thì ở dưới nó hiện calcultating..... Nhưng mở trên máy mình thì không bị gì hết. Máy mình và máy khác cấu hình giống nhau. Mình đã chỉnh chế độ auto cal cho mấy máy kia nhưng không khắc phục. Phải chon Manual thì mới khắc phục. Nhưng như vậy thì sợ khi mở những file khác tính toán thì kết quả tính toán không cập nhật nếu quên bấm F9. Các cao thủ giúp mình mới
 

HyperLink

Thành viên hoạt động
Tham gia ngày
8 Tháng năm 2008
Bài viết
171
Được thích
118
Điểm
0
Tuổi
36
Mình có 1 file chừng 40kb thôi. Mở ở máy 3-4 máy khác nhau thì bị lỗi: mỗi lần nhập thêm hay copy (nói chung là bất cứ thao tác gì) thì ở dưới nó hiện calcultating..... Nhưng mở trên máy mình thì không bị gì hết. Máy mình và máy khác cấu hình giống nhau. Mình đã chỉnh chế độ auto cal cho mấy máy kia nhưng không khắc phục. Phải chon Manual thì mới khắc phục. Nhưng như vậy thì sợ khi mở những file khác tính toán thì kết quả tính toán không cập nhật nếu quên bấm F9. Các cao thủ giúp mình mới
bạn gửi file lên diễn đàn để mọi người xem giúp nhé !
 

janguyen

Thành viên mới
Tham gia ngày
28 Tháng mười một 2010
Bài viết
1
Được thích
0
Điểm
0
Tuổi
30
file của mình cũng bị lỗi vì để nhiều công thức quá.
Nhờ các bạn xem và sửa giúp mình với
 
Lần chỉnh sửa cuối:

dongkisot84

Thành viên mới
Tham gia ngày
6 Tháng mười một 2007
Bài viết
24
Được thích
7
Điểm
665
Tôi mới khắc phục lỗi này, nguyên nhân chính xác là do bạn thiết lập 1 công thức chạy cho toàn bộ bảng tính ( như của tôi là hơn 10 ngàn dòng dữ liệu) dẫn đến file luôn phải trong tình trạng cập nhật dữ liệu liên tục. Sau khi xoá bỏ công thức đó đi xong file trở lại như bình thường
 

qtm07

Thành viên mới
Tham gia ngày
26 Tháng tám 2013
Bài viết
35
Được thích
1
Điểm
165
Tuổi
32
Mình cũng bị giống bạn ,thậm chí file mới tạo chưa có dữ liệu nào mà insert 1 cột nó cũng báo calculator chậm
 

nguyenhuy0405

Thành viên mới
Tham gia ngày
14 Tháng một 2008
Bài viết
11
Được thích
0
Điểm
0
Tuổi
37
Mình cũng bị lỗi calculating rất chậm, sử dung file mày lâu rồi, nhưng mới bị cách đây mấy ngày.
ACE diễn đàn test giúp mình nhé, cảm ơn nhiều lắm. Hu hu.
Flie 7 mb, nên em ko thể gửi được.
 

quangtanxnk

Thành viên mới
Tham gia ngày
21 Tháng tư 2017
Bài viết
1
Được thích
0
Điểm
0
Tuổi
29
mình cũng bị vậy. các anh chị em đã fix được lỗi đó chưa chỉ mình với
nó cứ chạy lỗi calculating rất chậm
 

tranquangchien90

Thành viên mới
Tham gia ngày
5 Tháng một 2017
Bài viết
8
Được thích
0
Điểm
163
Tuổi
29
- Một là bạn lên mạng tìm office khác download về rồi cài lại thử.
- Nếu không được có thể máy bạn đang chạy win 64bit thử hạ xuống win 32bit xem rồi cài lai office cũ là sẽ hết.
 

triphanminh77ktxd

Thành viên mới
Tham gia ngày
3 Tháng tư 2015
Bài viết
4
Được thích
1
Điểm
165
mình cũng bị vậy. các anh chị em đã fix được lỗi đó chưa chỉ mình với
nó cứ chạy lỗi calculating rất chậm
- Trước tiên bạn chọn về "Manual" sau đó tại mỗi Sheet trong Workbook bạn nhấn Ctrl + End => xác định được vùng dữ liệu bị chiếm dụng trong từng sheet (thường những file bị lỗi calcu thì vùng dữ liệu rất rộng), vùng nào không cần thì xóa hết đi rồi save lại là hết lỗi.
- Nếu cách này không được nữa thì làm theo cách của "tranquangchien90" nhé.
 

hongtrung186

Thành viên mới
Tham gia ngày
13 Tháng mười 2018
Bài viết
1
Được thích
1
Điểm
13
Tuổi
32
Với excel 2010: bạn vào file -> options -> Formulas -> Ở thẻ Workbook Calculation chọn "Automatic" --> OK
 
Top Bottom