Đăng ký học Excel và VBA cùng GPE tháng 11 - TPHCM

Đăng ký học Excel và phân tích số liệu cùng GPE tháng 12 - TPHCM

Mua sách "VBA trong Excel - Cải thiện và tăng tốc" tái bản

Lỗi đảo ngược ngày tháng trong trộn thư - mail merge

Thảo luận trong 'Những vấn đề chung' bắt đầu bởi cochieu, 28 Tháng mười một 2008.

  1. cochieu

    cochieu Thành viên mới

    Xin chào các bạn, có ai bit sử dụng Mail Merge, chỉ mình với!
    Khi mình sử dụng thao tác Mail Merge trong Word và Excel thì ngày tháng bị đảo ngược với nhau. Chẳng hạn, trong file Excel mình gõ ngày tháng năm sinh của Nguyễn Văn A là 28/11/2008, thì khi sử dụng thao tác Mail Merge trong file Word, thì ngày tháng của người này sẽ bị đảo thành là 11/28/2008.
    Trong file Excel mình đã mặc định ngày tháng năm theo dạng là dd/mm/yyyy.
    Bạn nào bit chỉ mình với nha. Thanks trước!!!:-=
     
  2. cop_kh

    cop_kh Hôm qua em đến trường...

    Bạn phải vào lại trong Control Panel>>Regional and Language Options>>Customize>>Chọn thẻ Date, trong phần Short date fomat bạn gõ lại là dd/MM/yyyy là OK thôi.
     
  3. cochieu

    cochieu Thành viên mới

    Trước đây, mình đã làm như vậy rồi nhưng cũng ko có tác dụng gì bạn à. Mình đang sử dụng Window Vista, và MW 2003. Hic!!!! sao mình làm ko dc nhỉ?
     
  4. cop_kh

    cop_kh Hôm qua em đến trường...

    Cũng khó hiểu nếu bạn đã làm như vậy mà vẫn không được @#!^%.
    Thôi bạn dùng cách khác tạm để giải quyết công việc nhé:
    B1: Copy cột dữ liệu ngày tháng (đã được định dạng kiểu dd/mm/yyyy) qua 1 file notepad.
    B2: Xóa cột dữ liệu ngày tháng trong cell rồi chọn Format>>Cells>>Number>>Text>>OK.
    B3: Copy lại cột ngày tháng trong Notepad rồi Paste lại vào cột ngày tháng trong Excel vừa được Format ở trên.

    Bây giờ thì OK để Mail Merge rồi đó bạn, nếu nó còn đảo ngược nữa thì bạn cứ lấy búa đập lên đầu của mình nhé +-+-+-+.

    Chúc thành công.
     
  5. cochieu

    cochieu Thành viên mới

    Cảm ơn bạn đã chỉ dẫn cho mình.
    Bạn ơi, mình thử làm rồi và nó cũng ko ok gì cả, các ngày tháng trong đó vẫn bị đảo ngược khi mình thực hiện Mail Merge. Còn cách nào khác nữa ko vậy bạn?
     
    Lần chỉnh sửa cuối: 1 Tháng mười hai 2008
  6. lieu0579

    lieu0579 Thành viên mới

    Ngày tháng bị đảo lộn trong trộn thư

    Mình đã phải làm cách này trong bản data những số liệu mặc định là số bạn thêm dấu ' vào trước là được ngay mà vi dụ ngày '31/12/2008 thì sang word nó tự nhận là dạng text theo nguyên bản là ngày 31/12/2008
     
  7. Billmama

    Billmama Thành viên mới


    Bạn ơi,

    Giúp mình, mình làm như cách của bạn hướng dẫn, nhưng trong merge lại hiện ra một dãy số. VD, file nguồn là 31/01/2009 thì trong word là 42155

    Cảm ơn bạn
     
  8. cop_kh

    cop_kh Hôm qua em đến trường...

    Nếu vẫn không được, bạn gởi File lên mình làm thử cho.
     
  9. tuancdnnt

    tuancdnnt Thành viên mới

    Hic!
    Mình cũng bị như vậy.
    in Bằng tốt nghiệp mà ngồi nhập lại chắc điên luôn, chưa kể bị sai sót.
    A! Cho mình hỏi tại sao khi trộn thư để in bằng thì kết quả chỉ nhận được font VNI còn các font khác không nhận được?
     
  10. vuthaomai

    vuthaomai Thành viên mới

    Mình vừa mày mò và đã làm được (trong excell và word 2007)

    1. Bạn click chuột phải vào field trong word, chọn Toggle Field Code, sau đó chép đoạn mã \@ "dd-MM-yyyy" và sau đoạn code là được.

    2. Đối với các yêu cầu chèn, format field khác, bạn cũng click chuột phải vào field, chọn Edit Field, chọn trong categories / field name cần thiếu, nhấn field codes cần thiết, copy các field codes vào đằng sau đoạn mã như mục 1.
     
  11. quean

    quean Thành viên mới

    Bạn ơi,
    Sao mình cũng làm như bạn, chọn Toggle Field Code, sau đó chép đoạn mã \@ "dd-MM-yyyy" nhưng nó lại hiển thị sai tháng. Ví dụ: 08/03/2012 thì nó hiện ra là 08-00-2012.
     
  12. minhtuanhnd

    minhtuanhnd Thành viên mới

    Rất đơn giản, mình cũng bị như bạn nhưng sau 30 phút tìm đủ mọi trò mà không được hóa ra lỗi này do các bạn chọn "Vietnamese" trong phần "Advanced" vì vậy các bạn hãy đổi tất cả "Vietnamese" trong Regional and Language Options về "English (United States)" sau đó khởi động lại máy và chỉnh định dạng ngày tháng về "dd/mm/yyyy). Xong nếu làm được thì thank mình nhá! mình đã thành công roài :D --=0
     
  13. anmaydaihiep

    anmaydaihiep Thành viên mới

    Mình đã làm như bạn và thành công. Nhưng mình gặp một lỗi như sau, mong mọi người giúp đỡ.
    Trong Toggle Field Code, mình muốn trên word thể hiện là Ngày ... tháng ... năm ... nên mình thêm đoạn mã như sau :
    Ngày { MERGEFIELD + Sheet ngày tháng muốn chèn + \@ "dd"} Tháng { MERGEFIELD + Sheet ngày tháng muốn chèn + \@ "MM"} Năm { MERGEFIELD + Sheet ngày tháng muốn chèn + \@ "yyyy"}
    - Vấn đề mình mắc phải ở đây là những ngày < 10 ( ví dụ 01/07/2013 ) thì nó hiện là "Ngày 07 tháng 01 năm 2013", bị ngược ngày tháng. Còn những ngày >10 (ví dụ 15/07/2013 thì nó hiển thị đúng. có cách nào để giải quyết vấn đề này ko mọi người?
     
  14. leonguyenz

    leonguyenz Thành viên mới

    Bạn thử xem lại thiết lập ngày tháng trong Control Panel là định dạng gì và chuyển về định dạng dd/MM/yyyy.
     
  15. phamducviet

    phamducviet Thành viên mới

  16. minhdang_9

    minhdang_9 Thành viên mới



    Chắc bạn không viết hoa hai chữ MM rồi!
     
    Lần chỉnh sửa cuối: 27 Tháng tám 2014
  17. minhdang_9

    minhdang_9 Thành viên mới

    Chắc do bạn không viết hoa hai chữ MM nên nó hiểu thành phút!
     
  18. Harry_Potter

    Harry_Potter Thành viên mới

    Cám ơn bạn nhiều nhiều! Đây là cách đỡ phiền phức nhất, nhưng không cần khởi động máy lại --=0
     
  19. ninhsut

    ninhsut Thành viên mới

    Chính xác luôn! Các bạn đổi lại thành \@ "DD-MM-YYYY" là được
     
  20. VANPHONG.VO89

    VANPHONG.VO89 Thành viên mới

    thanks bạn nha....mình làm được rồi nek...hi hi hi |||||||||||||||||||||||||__--____--____--____--____--____--__
     

Chia sẻ trang này